1)  On systems running Upstart, shorewall-init cannot reliably secure
    the firewall before interfaces are brought up.

2)  The 'enable', 'reenable' and 'disable' commands do not work
    correctly in configurations with USE_DEFAULT_RT=No and optional
    providers listed in the DUPLICATE column.

3)  The 'getrc' and 'getcaps' commands do not process the params file.

    Corrected in Shorewall 5.2.0.1.

4)  The getrc and getcaps commands added in 5.2.0 do not read the
    params file.

    Corrected in Shorewall 5.2.0.1.

3)  There is a shell syntax error in the code that implements the
    'ipdecimal' command.

    Corrected in Shorewall 5.2.0.1.

4)  The 'safe-' commands fail with the error:

        /usr/sbin/shorewall: 1194: /usr/sbin/shorewall:
	                           read_yesno_with_timeout: not found

    Corrected in Shorewall 5.2.0.2.

5)  When the -c option is specified with the 'compile' command, and
    AUTOMAKE=No or AUTOMAKE=, the command fails with errors such as:

      usr/sbin/shorewall: 415: [: =: unexpected operator
      /usr/bin/find: Expected a positive decimal integer argument to
                     -maxdepth, but got ‘-type’
      /usr/sbin/shorewall: 415: [: =: unexpected operator
      /usr/bin/find: Expected a positive decimal integer argument to
                     -maxdepth, but got ‘-type’

    Corrected in Shorewall 5.2.0.2.

6)  The 'show saves' command fails when there are no saved
    configurations.

    Corrected in Shorewall 5.2.0.2.

7)  The 'update' command does not replace Drop or Reject in the setting
    of BLACKLIST_DEFAULT.

8)  The 'update' command (and automatic conversion of the masq file)
    fail to handle variables of the form ${...} correctly, resulting in
    "Invalid column/value pair" errors.

    Corrected in Shorewall 5.2.0.3.

9)  If AUTOMAKE is not specified in shorewall[6].conf, the following
    Perl diagnostic was issued:

      Use of uninitialized value $val in pattern match (m//) at
      /usr/share/shorewall/Shorewall/Config.pm line 6602

    Corrected in Shorewall 5.2.0.3.

10) if an ethernet provider interface loses carrier, an attempt to
    disable the interface may result in an error similar to this:

      Error: "nexthop" or end of line is expected instead of "linkdown"
      ERROR: Command "ip -4 route replace table 250 default
             nexthop via 192.168.0.1 dev eth2 weight 1 linkdown" Failed

    Corrected in Shorewall 5.2.0.3.
